基于EasyHelper的对话框组件插件

基于EasyHelper的对话框组件插件

实现多功能的对话框功能,jQuery库,要求其最低版本不得低于3.2.0。

使用方法
引入CSS样式文件代码

1
<link rel="stylesheet" href="easyhelper.min.css">

引入脚本文件:

1
2
3
4
5
// es6-shim 针对的是不支持 es6 语法的浏览器
<script src="es6-shim.min.js"></script>
<script src="http://www.jq22.com/jquery/jquery-3.3.1.js"></script>
<script src="jquery.transit.min.js"></script>
<script src="easyhelper.min.js"></script>

设置示例按钮:

1
<button id="open-dialog">打开对话框</button>

创建对话框:

1
2
3
4
5
6
$( "#open-dialog" ).on("click", function () {
   Helper.ui.dialog({
       title: "对话框标题",
       content: "对话框内容"
   });
})
当前内容只有登录了才能查看,如果您已经注册,请登录
1

发表评论